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Installation

In order to use SUGARfx with Final Cut Studio, Motion, After Effects CS3 or CS4 and 
Final Cut Express, you need to download and install the Free FxFactory plug-in from 
Noise Industries.

	 FxFactory is the host plug-in that makes SUGARfx available to the applications, so you need to 
first download FxFactory from the Noise Industries web site.

• FxFactory is a free download and the web site address is:

http://noiseindustries.com/products/fxfactory/download/index.html

• Install and follow the prompts during installation.

Installing SUGARfx

You should have received the code and information via e-mail, and downloaded the SUGARfx pack on 
your computer.

If you successfully installed FxFactory, then the icon of the SUGARfx should look just like a square brown 
box shown here.

• Double click and it should automatically be moved to its correct place and ready to be used with your 
applications.

For more information on FxFactory, please read the instructions and/or the help file that came with it, or 
visit their support page on their web site (www.noiseindustries.com).

http://noiseindustries.com/products/fxfactory/download/index.html
http://noiseindustries.com
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Bubble Buddy

Bubble Buddy from SUGARfx

Bubble Buddy brings the talking bubble automatic creation on to your creative pipeline with ready-
made graphics that can be customized to create standard looking bubbles as well as off-the-wall unique 
talking bubbles.

Bubble Buddy is a filter inside Final Cut Pro and the other hosts found under the SUGARfx category, 
that can be applied to an asset on the time line. Its control parameters allow you to customize its colors, 
optional animation (either manual or automatic) and create unique combinations that can help you in 
the creation of your own style of talking bubble.
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Using Bubble Buddy

Open your host application and browse the Effects Menu or Tab.

The screen shots shown on this manual are from Final Cut Pro, but there should be no difference in the 
functionality of the SUGARfx plug-in in all of the other host applications.

Open Final Cut Pro / Express

Bubble Buddy can be found under the SUGARfx category in your Filters menu. 

If you want to use the Filter, you need to have a video asset in your time line before you try to access the 
filters menu.

As you may already know, the filters can be accessed in two different ways.

One way is by going into the Effects tab in the Browser window where you will find the Video Filters 
folder, and inside there you should find another folder containing the SUGARfx Bubble Buddy filter.

If you use this method to apply your filters, then select the filter of your choice and drag it and place it 
on top of the video asset in your time line until you see the video asset gets highlighted. Then, let the 
mouse go so the filter gets applied onto your video footage. 
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Another method to access the filters is as follows: you need to first select the video asset you want to 
affect and then go to the menu Effects > Video Filters > SUGARfx > Bubble Buddy.

After applying the filter using either method, you now have to double-click the affected video in the 
time line in order to see its control parameters in the Viewer window.

•	 Go to the Viewer window and click on the Filters tab to access its parameters. 

•	T here you can adjust the parameters to your liking, save presets or load your favorite ones.

Bubble Buddy has its own set of parameters and they can be customized as you desire.

In the following sections you will be able to learn about the parameters of this filter.
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Bubble Buddy is a filter that provides a way to add a custom talking bubble to your 
video or graphics in a simple, easy and fast way inside FCP, Motion, FCE and After 
Effects. Bubble Buddy can be animated manually or self animated by using its built-in 
animation provided in a simple selection box. 
 

After applying this filter, double-click the video affected and go to the Viewer window to access the 
parameters by selecting the Filters Tab. 

Parameters

•	 User Manual : One of the most important things you need to know about all of our products is 

Parameters
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that when you select the SUGAR logo or the USER MANUAL button on the interface, you will gain 
access to the on-line manual that you can either download or read on-line.

•	 Presets : If you would like to use a Preset, you can do that with the pull down menu, you can also 
create your own presets and save them or share them with your peers.

Here is where you can save your own Presets after customizing the look and setups you use the most.

Main Setup

This section allows you to set the main parameters where you can select what other parameters to 
enable and customize if necessary.

•	 Bubble Type : This pull down menu gives you two options. One is the Graphic type which is 
shown by default, and the second one is the 3d Look, which provides a collection of bubbles that 
were made in a tridimensional style. 
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•	 Bubble Content : This pull down menu allows you to select either Text or Image as the content 
of the bubble. Text is selected by default, but when you select Image, a new section called Image 
should appear in the interface where you can add a still image or a video clip to be inside the 
bubble. (See the Image parameters later on the manual).
 

•	 Position : Allows you to position the bubble anywhere on your screen.

•	 Pointer : By selecting this box you enable the Pointer of the bubble. It is enabled by default.
 

•	 Outline : The Outline makes your bubble stand out from the background, and with this button 
you have the option to enable or disable it at will.

•	 Color (outline) : Select the color of your outline from the Color Palette.

•	 Animation : Many parameters in this filter can be animated, so this pull down menu gives you 
three options: None, Come In and In & Out.
 

	 None [Manual] : Select this option when you want to animate the parameters yourself.

	 Come In : Select this option if you want the plug-in to use its built-in animation to bring the 
bubble on the screen.

	 In & Out : Select this option if you want the filter to bring the bubble in and out for a period of 
time.

	 When you select the Come In or the In & Out options, you will be presented with a couple of new 
parameters that will help you decide how long the bubble will stay on screen and how long the in 
and out animation will last. 
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	 Duration : You can set the duration (in seconds) of how long it will take the bubble to be on 
screen from the time it starts animating to the end when it is gone.

	 In & Out Duration : Here you can set the duration (in 10th’s of a second) of how long it will take 
for the bubble to animate In and animate Out. 

	 Note: The In & Out duration is shown in 10th’s of a second, therefore if you type 10, it translates to 1 second and if you
	 type 7 then it translates to 7/10th’s of a second or 0.7 seconds.

•	 Enable Edit Mode : Enable this mode when you need to see the bubble to make adjustment 
during those times when you have animated the position of the bubble off the screen, or when 
you have used the automatic In & Out animation and you are unable to see the bubble at that 
specific moment.

	T he Enable Edit Mode will show you the bubble in the middle of your Canvas and will show an 
arrow for the direction of the Pointer. A red cross-hair that shows where the Shadow is pointing 
at, and the width of the Margin for the text.

	 Make sure that you disable this mode before rendering or playing back your video edit. 
 

•	 Margin Edit Color : This parameter selects the color palette for the box that shows the margin of 
the text in your bubble. This is a visual aid to know where the margins of your text are.

Color Palette

Bubble Buddy comes with a special section where you can set the color palette used in your instance 
of this filter, and then apply the desired color number to the element in its own section. In other words, 
the Color Palette will make it easier to apply the same color to different elements and make changes 
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globally without the need to go to the element and change its color to match another color from 
another element of the same filter.

 

•	 Color (number) : Set the color for each of the 6 color variations available in this filter.

Bubble

In this section you are able to make adjustments to the Bubble Style selected in the Main Setup 
section.

•	 Style [Graphic] - [3d Look] : This pull down menu changes depending on the Bubble Style you 
selected in the Main Setup section.

•	 Size : Controls the size of the bubble.

•	 Color : This parameter allows you to select one of the available colors from the Color Palette.

•	 Additional Elements : By default this menu is set to None, but there are 2 additional options that 
you can select in order to add or enhance the look and feel of the basic bubble.
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Selection of the first option:

•	 Additional Elements > Auto Shadow : This element will add an automatic shadow with the 
same color as the Outline color.

•	 Shadow Direction : This option appears when the Auto Shadow has been selected.

	T his is an interactive control to set the direction and depth of the shadow. The further away from 
the bubble, the more pronounced the effect.

Selection of the second option:

•	 Additional Elements > Around Stuff : When you select this element, the user interface will 
provide additional options to choose from. The Around Stuff option is only available for the 
Style [Graphic] bubbles and not for the Style [3d Look] bubbles.

•	 Around Stuff : This option becomes available only when Around Stuff has been selected.

	T his option provides 3 different ways to enhance or “add stuff” around the bubble style selected; 
these are Selection A, Selection B and Selection C.
 

	 Note : Every bubble selected will have its corresponding “stuff” elements that fit visually within 
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the bubble, and they are unique to the bubble selection and not repeated on other bubbles.

•	 Opacity : This option becomes available only when Around Stuff has been selected, and 
provides a way to control the transparency of the element.

•	 Around Stuff Color : This option becomes available only when Around Stuff has been selected, 
and provides a way to select a color from the Color Palette section.

Pointer

This section is available only if the Pointer button is enabled in the Main Setup section, and allows you 
to adjust several parameters related to the pointer appearance.

•	 Style [Graphic] - [3d Look] : Pull down menu that allows you to select the Pointer of your choice. 
This menu changes dynamically depending on the Bubble Style selected in the Main Setup 
section, either Graphic or 3D Look, so it matches the look and style of the Bubble selection.
 

•	 Direction : Controls the aiming direction of the Pointer.

•	 Pointer Flip : Provides an easy way to turn or “flip” the Pointer to the other way.

•	 Size Adjust : As its name implies, this controls the size of the Pointer without changing the size of 
the bubble. (We strongly suggest to use it with creative caution).
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Text

This section is available only if the Bubble Content has been selected as Text in the Main Setup.
 

In this section you are able to add a text message, change the font, size, color and other adjustments 
related to your text.

•	 Text Margin Width : Adjust the margin width of your text.  When Edit Mode is enabled in the 
Main Setup section, the Text Margin Width can be seen as a colored box behind the text that 
you can make the changes visually and interactively. 
 

Keep in mind that you can change the Color of the visual representation of the Margin by going back into the Main Setup section 
and selecting another color from the pull down menu, or by changing the corresponding Color (number) in the Color Palette 
section (shown above the color palette selected is Color 6).

•	 Text : By clicking on the Edit button you can enter new text or edit the text in your bubble. You 
can also import a Text File by clicking the appropriate button.

•	 Font Name : Select a font and the style of your text.
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•	 Text Color : Allows you to select one of the Color Palette available.

•	 Justification : Make a selection of how you want the text justified (Right, Left and Centered).

•	 Font Size : Selects the size of your font or text.

•	 Kerning : Controls the separation between the letters.

Image

This section is available only if the Bubble Content has been selected as Image in the Main Setup.
 

In this section you are able to add a video clip or still image inside the bubble instead of text, and make 
some adjustments related to its appearance. 
 

•	 Video Image 1 : This is the image well where you can drag-and-drop your video clip or image.

	 Keep in mind that the duration of the video clip needs to be long enough to last for the duration 
of the bubble on screen, otherwise the video clip will disappear abruptly before the bubble goes 
away.

•	 Adjust : This slider will move the video or image in the direction that it can according to the 
proportions of the image, so if the image is wider than tall, then the adjust slider will move it 
horizontally instead of vertically.

•	 Color : Sets the color of the element by selecting a Color number from the Color Palette.

•	 Add Composite : Changes the composite mode from Normal to Add, making it blend with the 
bubble and usually increasing luminosity.

•	 Intensity : Controls the Intensity or transparency of the Video Image.
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Presets

The presets expand your plug-ins even further, specially when you can create your 
own styles and setups and save them for later use.

Some of the SUGARfx filters already include several presets that you can use. 

In some cases it is a good idea to begin your own customizing by selecting one of the included presets 
and use it as a starting point to create your own.  

Have fun and start making your own, and remember that you can share the presets with other users or 
other computers as long as they have the same versions installed in their system.
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Support

Every SUGARfx theme or plug-in that you purchase comes with free technical support 
by sending all your questions via e-mail to our Support Team.

Our Technical support team is available to answer your questions via e-mail and should respond within 
24 hours or less from the time the e-mail was received.

Things to know before contacting Technical Support

Please visit our web site (http://www.sugarfx.tv) for possible answers to your technical support issues, 
or visit our tutorial site (http://www.ilearnfast.com) where you may also find a tutorial that will help you 
find the answer to your question before you contact our Support team.

If you cannot find the answer you need, please send us an e-mail to :  support@sugarfx.tv with the 
following information:

•	N ame and version of the SUGARfx theme.

•	T he version of the FxFactory.

•	 Your system configuration (Mac OS X version, RAM and whatever else you may think to be 
helpful)

•	T he application name and version with which you are having the problem.

•	S creen shots of the problem (whenever possible).

•	 Details and any other information you may think appropriate to describe the problem.

Feedback

The success of our products depend vastly on customer requests and feedback.

We welcome all kinds of e-mails that provide useful information on how to improve our products, so we 
encourage you, as a user of these products, to send us your feedback or comments to our support team.
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http://www.ilearnfast.com
mailto:support@sugarfx.tv

